Installation error

Mar 26, 2013 at 10:04 AM

I'm trying to install this solution on a Sharepoint Foundation 2010 and I've this error :
"operation is not valid due to the current state of the object"
Line 1 Char : 15

I tryed these 2 commands :

Add-SPolution "c:\Permissionsmanager2010.wsp" (with and without -LiteralPath)
stsadm -o addsolution -filename .\PermissionsManager2010.wsp

I've the same error everytime.

Is-it a problem due to the langage of sharepoint ? He's installed in french
Mar 26, 2013 at 11:01 AM

It's not a problem with language, my SPS2010 farm is in french too.

I think that it's an issue linked to your environment, try Google with your error message, you'll find a lot of topics.

Good luck,
Mar 27, 2013 at 2:20 PM
Yes indeed;

I had not the time to read everything until this afternoon.

I solved this by creating a folder in "ProgramData/Microsoft/Sharepoint/Config" with the name of the registry key "ID" in Local_machine/software/microsoft/Shared tool/Web server Extension/14.0/Secure/ConfigDB

And all my xml files appeared